Problème compositing "combined" dans soft 2D.

Ici on parle du compositing

Modérateurs : frez, Yadoob, stilobique, Matpi, ModSquad

Problème compositing "combined" dans soft 2D.

Message par orgelf » 25 Juil 2016, 09:31

Bonjour tout le monde j'ai quelques questions concernant le compositing de passes 3D dans un soft 2d.


Je sais qu'une grande majorité ici connait le principe mais je vais quand même expliquer rapidement pourquoi cette question.

Une image 3d est composée de plusieurs images ( appelées passes) combinées entre elles dans le soft afin de constituer l'image finale ( appelé rendu). En général au moment du calcul final , on demande au logiciel de n'avoir que ce résultat final.

Mais on a aussi la possibilité de demander á avoir les différentes passes distinctes dans un même fichier ( au format openEXR multilayers 32 bits) ou séparément (png entre autres) , puis importer ce fichier dans Photoshop et reconstituer le rendu en jouant sur les modes de fusion. L'intérêt alors est que l'on a une totale maîtrise sur l'image finale.


1. OpenEXR Multilayers


Mon problème est le suivant. Quand je crée mes passes en 32 bits et les reassemble dans Photoshop, aucun problème, mon compositing a le même aspect que le rendu dans le soft 3d. Mais quand je passe l'image en 16 ou 8 bits , mon image change complètement comme si les modes de fusion ne réagissaient pas de la même manière.
Et ce que l'image soit en multicalques ou aplatie.

Quelqu'un aurait une idée de la manoeuvre á effectuer pour pouvoir passer au 16 bits sans problèmes ?


deux images pour vous montrer le problème.

composite en 32 bits.

Image


composite 16 bits.


Image



2.PNG 16 bits



Sinon, j'ai aussi essayé le compositing externe à partir de fichiers en png 16 bits. Là ça va un peu mieux sauf que j'ai l'impression que mes ombres ont disparues. J'ai paramétré la création d'un passe shadow mais je me retrouve avec une image noire (RGBA activé lors du rendu).

Test réalisé à partir d'une autre version du fichier.


le combined classique de Blender.


Image


le composite dans Photoshop



Image




ps: Merci de votre aide et excellente journée !
Avatar de l’utilisateur
orgelf
 
Message(s) : 230
Inscription : 30 Oct 2013, 13:30
Localisation : Paris

Re: Problème compositing "combined" dans soft 2D.

Message par VincentG » 25 Juil 2016, 11:10

Dur à dire comme ça car je n'ai pas Photoshop mais à mon avis c'est une question de color splace. Lineaire ou sRGB. Essaie de changer ce mode sous photoshop et vois ce que ça donne.
http://www.vincentgires.com
Belgian Blender User Group : http://bbug.be/
Avatar de l’utilisateur
VincentG
 
Message(s) : 221
Inscription : 13 Fév 2014, 21:35

Re: Problème compositing "combined" dans soft 2D.

Message par orgelf » 25 Juil 2016, 12:04

Merci VincentG,

Je viens de faire des recherches dans ce sens mais ça n'a pas l'air de fonctionner.

Pourtant sur cette vidéo, le problème exactement le même que le mien, j'ai téléchargé son profil ICC, installé et même si il y a du mieux, c'est loin d'être encore ça...

Voici un lien vers la vidéo en question, le problème est présenté et résolu (3'-->7')

https://www.youtube.com/watch?v=GwHj7vmp-og
Avatar de l’utilisateur
orgelf
 
Message(s) : 230
Inscription : 30 Oct 2013, 13:30
Localisation : Paris


Retour vers Compositing

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Bing [Bot] et 1 invité