installation de animation nodes 2.1.3 w10 openvdb

Ici on parle des scripts

Modérateurs : frez, Yadoob, stilobique, Matpi, ModSquad

installation de animation nodes 2.1.3 w10 openvdb

Message par Nicolas R » 04 Mars 2019, 20:16

Bonjour à tous et à toutes.

Je viens de tomber sur le addon "openvdb remesh" qui dans la dernière version, propose une installation de AN 2.1.3 avec des nodes pour faire du modelingvdb non destructif, comme dans Cinema4d, Maya, Lightwave, Houdini, on est sur un truc vraiment génial.
Seulement je bloque sur le fait que Blender 2.8 me signale au moment de cocher la case d'activation de l'addon que j'ai plusieurs versions d'installées sur ma dernière version de la 2.8 toute fraîche, alors que j'ai tout désinstallé mais je dois merder quelque part c'est sûr, mais là je sèche carrément, je suis sur windows 10. Si quelqu'un c'est déjà trouvé dans cette situation et à trouvé une solution je serais bien preneur merci d'avance pour votre aide ?
Avatar de l’utilisateur
Nicolas R
 
Message(s) : 92
Inscription : 13 Août 2013, 16:03

Re: installation de animation nodes 2.1.3 w10 openvdb

Message par zeauro » 04 Mars 2019, 22:35

Je n'ai pas testé les AN pour la 2.8 et de toute façon, je suis sous linux.
Mais j'ai peut-être une piste pour toi.

Les animation nodes à partir de la v2, c'est du cython.
Pendant l'installation, il faut compiler l'addon et il faut définir une variable d'environnement pour permettre à la partie python d'appeler la partie en C.
Il est probable que faire une désinstallation manuelle, en supprimant les fichiers, ne règle pas la question de la variable d'environnement se référant toujours à l'ancienne version.
zeauro
 
Message(s) : 969
Inscription : 21 Août 2013, 15:47

Re: installation de animation nodes 2.1.3 w10 openvdb

Message par Nicolas R » 04 Mars 2019, 22:40

merci à toi Zeauro, je vais creuser dans ce sens
Avatar de l’utilisateur
Nicolas R
 
Message(s) : 92
Inscription : 13 Août 2013, 16:03

Re: installation de animation nodes 2.1.3 w10 openvdb

Message par Nicolas R » 07 Mars 2019, 21:46

Ok en fait j'ai maté cette vidéo et je suis allé nettoyer tout mon bordel dans le dossier
C:\Users\"User"\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons

indiqué dans cette vidéo et zou, ça marche ;)
https://www.youtube.com/watch?v=xTMqFK9 ... e=youtu.be

Image
Avatar de l’utilisateur
Nicolas R
 
Message(s) : 92
Inscription : 13 Août 2013, 16:03


Retour vers Scripts - Python - OSL

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 2 invité(s)

cron