[Résolu] Bug ?? sur le Loop cut and slide sur 2.72 officiel

Ici on parle de modélisation

Modérateurs : frez, Yadoob, stilobique, Matpi, ModSquad

[Résolu] Bug ?? sur le Loop cut and slide sur 2.72 officiel

Message par StefP29 » 10 Déc 2014, 14:26

J'ai constaté une anomalie sur la création et la position de loop, voir un sacré problème.

Explication et à tester chez vous :

J'ai créé un cube sans retoucher la taille, déplacement, etc, puis Edit.

Donc "ctrl R" (loop cut) et déplace le loop en maintenant la touche ctrl (pour des pas de 0.1 à 0.1) sur l'axe Y donc je m'arrête à 0.8 pour un côté et l'autre à -0.8. Testé aussi sur l'axe X, Z bug idem...

Déjà on voit que l'écart des loops par rapport aux angles du cube ne sont pas identiques.

J'ai mesurer avec l'outil Measure en prenant le point d'une extrémité du cube et du point de la loop la plus proche et je trouve 0.2 BU d'un côté et 0.18 BU de l'autre.

Qu'en pensez-vous ?

Avez vous testé, si ce n'est pas un bug, alors pourquoi il y a un tel écart ?
Dernière édition par StefP29 le 10 Déc 2014, 15:06, édité 1 fois.
Avatar de l’utilisateur
StefP29
 
Message(s) : 293
Inscription : 13 Avr 2014, 11:54

Re: Bug ?? sur le Loop cut and slide sur 2.72 officiel

Message par ArnaudT » 10 Déc 2014, 14:35

hmmm..zarb, je n'ai pas ce souci chez moi avec la 2.72b.
Infographiste 3D freelance - http://www.arnaud-travert.com/
Avatar de l’utilisateur
ArnaudT
 
Message(s) : 454
Inscription : 30 Août 2013, 07:25
Localisation : Rennes

Re: Bug ?? sur le Loop cut and slide sur 2.72 officiel

Message par StefP29 » 10 Déc 2014, 14:42

J'ai la 2.72b.

T'as fait la manip ?

Si tu sélectionnes un edge de la loop t'as un -0.8 qui s'affiche et l'autre côté 0.82.

Pourquoi cela fait ça chez moi ?
Avatar de l’utilisateur
StefP29
 
Message(s) : 293
Inscription : 13 Avr 2014, 11:54

Re: Bug ?? sur le Loop cut and slide sur 2.72 officiel

Message par zeauro » 10 Déc 2014, 15:08

C'est le comportement normal.
Le factor du edge slide est une valeur proportionnelle à la longueur du edge coupé entre -1 et 1.

Donc sur le cube de base de 2 BU, le premier cut à 0.8 va partir du milieu et couper la moitié positive qui correspond à une longueur de 1 BU. On a donc une correspondance avec un petite partie créé de 0.2BU de large.
Mais pour le second cut, on coupe une partie qui fait 1,8BU de long.
Donc un facteur de -0.8 coupe la partie négative qui à partir de son milieu ne fait que 1,8/2 = 0.9 BU.

La petite partie restante de ce côté a donc une longueur de 0.9x0.2 =0.18 BU
zeauro
 
Message(s) : 972
Inscription : 21 Août 2013, 15:47

Re: Bug ?? sur le Loop cut and slide sur 2.72 officiel

Message par StefP29 » 10 Déc 2014, 15:18

CQFD, et tu fais comment pour être plus précis ?
Avatar de l’utilisateur
StefP29
 
Message(s) : 293
Inscription : 13 Avr 2014, 11:54

Re: Bug ?? sur le Loop cut and slide sur 2.72 officiel

Message par bjo » 10 Déc 2014, 15:21

Tu zoomes et à l'oeil (de toutes ça se verra pas) ou tu snapes (mais pas en edge slide)
Avatar de l’utilisateur
bjo
 
Message(s) : 524
Inscription : 11 Août 2013, 22:30

Re: Bug ?? sur le Loop cut and slide sur 2.72 officiel

Message par StefP29 » 10 Déc 2014, 15:25

Oui, sinon je tape les valeurs directe.

Merci Zeauro pour tes explications et de votre aide à tous.
Avatar de l’utilisateur
StefP29
 
Message(s) : 293
Inscription : 13 Avr 2014, 11:54

Re: Bug ?? sur le Loop cut and slide sur 2.72 officiel

Message par ArnaudT » 10 Déc 2014, 19:26

ouais bah je n'ai pas été d'une grande aide de mon côté dans la mesure où je n'ai pas dû faire la même chose ^^
Infographiste 3D freelance - http://www.arnaud-travert.com/
Avatar de l’utilisateur
ArnaudT
 
Message(s) : 454
Inscription : 30 Août 2013, 07:25
Localisation : Rennes

Re: Bug ?? sur le Loop cut and slide sur 2.72 officiel

Message par StefP29 » 10 Déc 2014, 21:46

Pas grave !

J'ai encore appris quelque chose aujourd'hui.
Avatar de l’utilisateur
StefP29
 
Message(s) : 293
Inscription : 13 Avr 2014, 11:54


Retour vers Modélisation

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 2 invité(s)