Problème HDRI

Ici on parle de textures et dépliages d'uv's

Modérateurs : frez, Yadoob, stilobique, Matpi, ModSquad

Problème HDRI

Message par geds3169 » 14 Juin 2017, 17:29

Salut à tous, dans le cadre du concours Macro, j'ai commencé ma modélisation, et mis une HDRI.

Mon soucis est que j'ai besoin que d'avoir un reflet dans l'eau et que je n'ai que partiellement le ciel dans cette eau, s'est à dire que c'est un environnement gazon bordé d'arbre, et j'ai bien le ciel qui se reflète au loin mais dans la partie basse de la caméra j'ai l'impression de voir le gazon, je ne sais pas comment corriger cela, dois-je faire le fond de la surface de mon étendue d'eau, pour éviter cela ?

Je mettrais bien une capture d'écran mais je ne voudrais pas gâcher la surprise.

Cordialement
geds3169
 
Message(s) : 218
Inscription : 07 Juin 2015, 15:04

Re: Problème HDRI

Message par cgranjon » 15 Juin 2017, 13:24

Assez difficile d'aider sans images, parce que ton soucis vient principalement de la relation entre l'angle de camera et l'angle d'incidence de la surface de l'eau.
Avatar de l’utilisateur
cgranjon
 
Message(s) : 280
Inscription : 07 Août 2013, 16:19
Localisation : Londres

Re: Problème HDRI

Message par jemian » 15 Juin 2017, 13:38

tu peux faire tourner la hdri avec un node mapping.Si t'as pas de fond selon l'angle de la caméra on risque de voir par transparence le gazon de l'HDRI
Avatar de l’utilisateur
jemian
 
Message(s) : 2726
Inscription : 03 Fév 2014, 01:52
Localisation : Brest

Re: Problème HDRI

Message par geds3169 » 16 Juin 2017, 08:06

Merci à vous deux d'avoir répondu, vous confirmez ce que je pensais, j'ai donc tester avec le texture coordinate et le mapping, et cela ne change rien, cela vient en effet de la transparence. (c'est donc la memerde).

j'ai donc entrepris de faire un sol et juste une flaque d'eau au lieu d'une grande étendue d'eau, maintenant je rencontre deux autres soucis:

J'ai eu a deux reprise l'onglet des textures qui a disparu (l'icone carré rouge et blanche pas la boule jaune et noire, donc impossible de mettre un brush) après deux ré-ouverture de mon fichier celui-ci est revenu.

Ensuite avec juste 1000 particules j'ai mon Blender qui rame de fou, je suis sur le CPU, et j'ai quasi pas de mesh, alors bien sur j'ai du Displace, mais est ce que c'est cela qui pose problème ?.
geds3169
 
Message(s) : 218
Inscription : 07 Juin 2015, 15:04

Re: Problème HDRI

Message par geds3169 » 16 Juin 2017, 19:18

Re coucou, alors bon j'ai réussi a corriger mon problème, mais j'ai un nouveau soucis mais ce coup si avec un beau screen:
Image

Donc j'essaye désespérément de faire la transparence avec un double UV et cela ne fonctionne pas, j'ai bien fait mon positionnement avec U, mis d'un côté en faisant l'UV maps front, ensuite créer un second UV maps back et déplacé mon UV et ensuite fait mon cycle node. (c'est une méthode de http://www.reynantemartinez.com/ dans ses tutos).

Donc j'ai bien la "double" texture, mais pas la transparence (si vous n'aviez pas compris :lol: ).

Une idée peu être ?

Pour info cette texture fonctionne bien sur un autre fichier blender.

Si je prends une autre texture en png qui fonctionne sur un arbre du même blend celle si ne fonctionne pas non plus (avec un simple node de transparence)
geds3169
 
Message(s) : 218
Inscription : 07 Juin 2015, 15:04

Re: Problème HDRI

Message par geds3169 » 16 Juin 2017, 21:21

Résolu
geds3169
 
Message(s) : 218
Inscription : 07 Juin 2015, 15:04

Re: Problème HDRI

Message par jemian » 17 Juin 2017, 08:13

une feuille est translucide
donc un node translucent lié a un gloosy (parce qu'il y a toujours un peut de brillant sur les feuilles)
irait mieux qu'un simple diffuse
Avatar de l’utilisateur
jemian
 
Message(s) : 2726
Inscription : 03 Fév 2014, 01:52
Localisation : Brest

Re: Problème HDRI

Message par geds3169 » 17 Juin 2017, 09:03

tu as un exemple Stp ?
geds3169
 
Message(s) : 218
Inscription : 07 Juin 2015, 15:04

Re: Problème HDRI

Message par jemian » 17 Juin 2017, 18:47

ben c'est simple de mix diffuse avec glossy puis translucent
Image
Avatar de l’utilisateur
jemian
 
Message(s) : 2726
Inscription : 03 Fév 2014, 01:52
Localisation : Brest


Retour vers Textures

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron