shader subsurface rend noir ou très sombre

Ici on parle de Cycles et d'autres moteurs de rendu

Modérateurs : frez, Yadoob, stilobique, Matpi, ModSquad

shader subsurface rend noir ou très sombre

Message par DotByOne » 29 Juil 2018, 12:42

Bonjours,

dans le passé j'ai déjà eu des objets "noirs" (des transparents) j'ai augmenté la transparency et tout est rentré dans l'ordre.

Actuellement j'ai des reflets noirs dans certaines scenes (grosses) mais pas dans toutes, et pas dans certaines où il y a beaucoup de glaces (pas celles qu'on mange - les autres) sur des objets ayant un shader de subsurface pas sur les autres même transparents (j'ai changé tout les paramètres (en grande partie au pif) ça n'a rien changé.

Quelque soit la version de la 2.79 (denoiser oblige) viewport et render view.

Enfin, une curiosité: si j'éloigne l'objet de la scene (dans le même layer ou non ) l'effet disparait.

A part reconstruir les shader (pas ma tasse de thé) une solution?

PS: au cas où GPU RADEON PRO 570 mais en rendu j'utilise le proc.

Merci d'avance.
DotByOne
 
Message(s) : 18
Inscription : 18 Jan 2016, 16:35

Re: shader subsurface rend noir ou très sombre

Message par PtiLuky » 01 Août 2018, 09:10

Il est possible que certaines parties transparentes soient noires après trop de passages à travers une surface transparente par exemple.
Dans Render -> Light Path, tu peux régler le nombre de fois max qu'un rayon peut être transmis/réflechi/... avant d'être ignoré, si tu joues avec ces valeurs (en essayant de les garder le plus bas possible pour les performances), ça change quelque chose ?
Avatar de l’utilisateur
PtiLuky
 
Message(s) : 19
Inscription : 05 Nov 2013, 13:49
Localisation : Lyon

Re: shader subsurface rend noir ou très sombre

Message par DotByOne » 02 Août 2018, 08:45

Bonjours,

J'ai essayé de modifier les paramètres du rendu mais peu ou pas d'évolution. Mais j'ai trouvé une solution:

key, fill et back light même pour les images de jour. Cela élimine les reflets vert sur la peau (il en reste quelque un que j'élimine dans DaVinci).

C'est curieux c'est presque comme des prises de vue réelles. Merci quand même. Sauf que tout disparait quand mes immeubles sont repoussés au loin.
DotByOne
 
Message(s) : 18
Inscription : 18 Jan 2016, 16:35

Re: shader subsurface rend noir ou très sombre

Message par zeauro » 03 Août 2018, 19:48

Le subsurf peut avoir du mal à être précis avec des meshes trop cubiques.
En les éloignant, tu diminues la demande de précision. Tu peux essayer de mettre des bevels ou de les subdiviser.
Ou encore essayer en utilisant le master. Histoire de voir ce que ça donne avec la méthode Random Walk.
zeauro
 
Message(s) : 930
Inscription : 21 Août 2013, 15:47


Retour vers Rendu - moteurs de rendu

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 0 invité(s)